
<!DOCTYPE html>
<html lang="en">
<head><meta charset="utf-8" /><meta http-equiv="X-UA-Compatible" content="IE=edge" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>
	At The Corner in Ypsi, young people find health care that's affordable, holistic and judgement-free
</title><link rel="alternate" type="application/rss+xml" title="Subscribe to the Model D RSS feed!" href="https://feeds.feedburner.com/ModelDMedia" />
<link rel="shortcut icon" href="/images/favicon.ico" />
<link rel="icon" type="image/png" href="/images/favicon.png" />
<link rel="canonical" href="https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" />
<meta property="og:site_name" content="Model D" />
<meta property="og:title" content="At The Corner in Ypsi, young people find health care that&#39;s affordable, holistic and judgement-free" />
<meta property="og:image" content="https://www.modeldmedia.com/Images/Features/versell-smith-cropped-photo-2_1.jpg" />
<meta property="og:image:width" content="408" />
<meta property="og:image:height" content="427" />
<meta property="og:description" content="" />
<meta property="fb:admins" content="1054316675" />
<meta property="fb:admins" content="674682725" />
<meta property="fb:admins" content="1212364057" />
<meta property="fb:app_id" content="265187643498933" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@modeld" />
<meta name="twitter:title" content="At The Corner in Ypsi, young people find health care that&#39;s affordable, holistic and judgement-free" />
<meta name="twitter:url" content="https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" />
<meta name="twitter:image" content="https://www.modeldmedia.com/Images/Features/versell-smith-cropped-photo-2_1.jpg" />
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/css/bootstrap.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity@2.2.1/dist/flickity.min.css">
<link rel="stylesheet" href="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.css">
<link rel="stylesheet" type="text/css" href="/css/combined.min.css?v=637759407073396143" />
<link rel="stylesheet" type="text/css" href="/css/site.css?v=637178839140000000" />
<script type="text/javascript" src="/script/combined.min.js?v=637456080900000000"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js"></script>
<script type="text/javascript">OA_zones = {'Footer 01':2513,'Footer 02':2514,'Footer 03':2515,'Footer 04':2516,'Footer 05':2517,'Footer 06':2518,'Footer 07':2519,'Footer 08':2520,'Footer 09':2521,'Footer 10':2522,'Footer 11':2523,'Footer 12':2524,'Half Page 1':5755,'Leaderboard 2':3106,'Leaderboard 3':3107,'Masthead Leaderboard':3098,'Rectangle 1':3100,'Rectangle 2':3101,'Rectangle 3':3102,'Rectangle 4':3103,'Rectangle 5':3104,'Rectangle 6':3105};
</script>
<script type='text/javascript' src='https://dsx.issuemediagroup.com/www/delivery/spcjs.php?Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project'></script>
<meta name="description" content="" />
<meta name="keywords" content="" />
<script>(function (p, i, c, o) { var n = new Event("pico-init"); i[p] = i[p] || function () { (i[p].queue = i[p].queue || []).push(arguments) }, i.document.addEventListener("pico-init", function (e) { var t = i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i); t.handleQueueItems(i[p].queue), i[p] = function () { return t.handleQueueItems([arguments]) } }, !1); var e = i.document.createElement("script"), t = i.document.getElementsByTagName("script")[0]; e.async = 1, e.src = c, e.onload = function (e) { return i.Pico.getInstance(e, { publisherId: o, picoInit: n }, i) }, t.parentNode.insertBefore(e, t) })("pico", window, "https://gadget.pico.tools/wrapper.min.js", "52fefa58-9109-4d32-b0bd-5263d4f5a9ec");</script>
<script>
var isRootSite = true;
</script>
<script type="text/javascript">
var google_domain = 'www.modeldmedia.com';
var google_cx = '006919356486600035371:mgpz825q-w0';
var google_cof = 'FORID:11';
var site_base_url = '';

(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create','UA-225509-1','auto');


ga('send', 'pageview');


$(function () {
// ref:http://www.axllent.org/docs/programming-tips/google-analytics/
    $(document).find('body').click(
        function _gaLt(event) {
            var el = event.srcElement || event.target;
            while (el && (typeof el.tagName == 'undefined' || el.tagName.toLowerCase() != 'a' || !el.href))
                el = el.parentNode;
            if (el && el.href && el.href.indexOf(location.host) == -1) {
                // for universal analytics, swap line below for _gaq.push line
                ga("send", "event", "Outbound Link", el.href, document.location.pathname + document.location.search);
                
                //_gaq.push(["_trackEvent", "Outbound Link", el.href, document.location.pathname + document.location.search]);
                /* if target not set then delay opening of window by 0.5s to allow tracking */
                if (!el.target || el.target.match(/^_(self|parent|top)$/i)) {
                    setTimeout(function () {
                        document.location.href = el.href;
                    }.bind(el), 500);
                    event.preventDefault ? event.preventDefault() : event.returnValue = !1;
                }
            }
        }
    );
})
</script>

<!--[if lt IE 9]>
<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
<![endif]-->
</head>
<body class="model-d ch-feature-story FeaturedStory no-masthead">
<div id="fb-root"></div>
<script type="text/javascript">
var facebookAppId = '265187643498933';
</script>
<form name="aspnetForm" method="post" action="./At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" id="aspnetForm">
<div>
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="nT7sCbPq98XmjI4Dhk8Q4ljHSdq8BlTcA0rkxFEouHqWSZX0HeH++9oNTeXdeLz4aAUlvAmPeYaWxUkwhBRmSA8QhwE=" />
</div>
<div class="container-fluid page-container ">
<div class="container-fluid headerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="header">
<nav class="top-nav navbar navbar-inverse navbar-fixed-top">
<div class="container">
<div class="navbar-header">
<div class="navbar-header-wrapper">
<ul class="nav navbar-nav focus-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/focusareas/architecture.aspx'>Architecture</a></li><li><a href='/focusareas/arts.aspx'>Arts</a></li><li><a href='/focusareas/Buildingcommunities.aspx'>Building Communities</a></li><li><a href='/focusareas/entrepreneurs.aspx'>Entrepreneurs</a></li><li><a href='/focusareas/film.aspx'>Film</a></li><li><a href='/focusareas/green.aspx'>Green</a></li><li><a href='/focusareas/greentech.aspx'>Green Tech</a></li><li><a href='/focusareas/highered.aspx'>Higher Ed</a></li><li><a href='/focusareas/Jobcreation.aspx'>Job Creation</a></li><li><a href='/focusareas/michigannightlightfocus.aspx'>Michigan Nightlight</a></li><li><a href='/focusareas/mobility.aspx'>Mobility</a></li><li><a href='/focusareas/movetodetroit.aspx'>Move to Detroit</a></li><li><a href='/focusareas/neighborhoodinnovation.aspx'>Neighborhood Innovation</a></li><li><a href='/focusareas/redevelopment.aspx'>Redevelopment</a></li><li><a href='/focusareas/reuserebuild.aspx'>Reuse / Rebuild</a></li><li><a href='/focusareas/shoplocal.aspx'>Shop Local</a></li><li><a href='/focusareas/smallbusines.aspx'>Small Business</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Innovation</a></li><li><a href='/focusareas/talentdividend.aspx'>Talent Dividend</a></li><li><a href='/focusareas/transit.aspx'>Transit</a></li><li><a href='/focusareas/urbanfarming.aspx'>Urban Farming</a></li><li><a href='/focusareas/urbanleadership.aspx'>Urban Leadership</a></li><li><a href='/focusareas/woodwardave.aspx'>Woodward Avenue</a></li><li><a href='/focusareas/workforcetalentdevelopment812.aspx'>Workforce/talent development</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Neighborhoods<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/cities/brightmoor.aspx'>Brightmoor</a></li><li><a href='/cities/centralwoodward/default.aspx'>Central Woodward-Boston Edison</a></li><li><a href='/cities/cody-rouge.aspx'>Cody Rouge</a></li><li><a href='/cities/corktown/default.aspx'>Corktown</a></li><li><a href='/cities/downtown/default.aspx'>Downtown Detroit</a></li><li><a href='/cities/eriverfront/default.aspx'>East Riverfront</a></li><li><a href='/cities/eastside/default.aspx'>East Side</a></li><li><a href='/cities/easternmarket/default.aspx'>Eastern Market</a></li><li><a href='/cities/grandmtrsdl/default.aspx'>Grandmont Rosedale</a></li><li><a href='/cities/hamtramck/default.aspx'>Hamtramck</a></li><li><a href='/cities/highlandprk/default.aspx'>Highland Park</a></li><li><a href='/cities/jeffeast/default.aspx'>Jefferson Chalmers</a></li><li><a href='/cities/lafayetteprk/default.aspx'>Lafayette Park</a></li><li><a href='/cities/live_6.aspx'>Live 6</a></li><li><a href='/cities/mexicantown/default.aspx'>Mexicantown</a></li><li><a href='/cities/midtown/default.aspx'>Midtown</a></li><li><a href='/cities/neareastside/default.aspx'>Near East Side</a></li><li><a href='/cities/newcenter/default.aspx'>New Center</a></li><li><a href='/cities/north_end.aspx'>North End</a></li><li><a href='/cities/osborn.aspx'>Osborn</a></li><li><a href='/cities/swdetroit/default.aspx'>Southwest Detroit</a></li><li><a href='/cities/thevillages/default.aspx'>The Villages</a></li><li><a href='/cities/univcommons/default.aspx'>University Commons - Palmer Park</a></li><li><a href='/cities/woodbridge/default.aspx'>Woodbridge</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav resources-nav hidden-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="true">Series & Events<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2">
<div class="row">
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Series</li>


<li><a href="/series/block-by-block.aspx">Block by Block</a></li>
<li><a href="/series/blue-green-infrastructure.aspx">Blue/Green Infrastructure</a></li>
<li><a href="/series/bridging-the-talent-gap.aspx">Bridging the Talent Gap</a></li>
<li><a href="/series/children-of-michigan.aspx">Children of Michigan</a></li>
<li><a href="/series/community-redistricting.aspx">Community Redistricting</a></li>
<li><a href="/series/voices-of-cody-rouge.aspx">Voices of Cody Rouge</a></li>

<li><a href="/series/detroit-driven.aspx">Detroit Driven</a></li>
<li><a href="/series/DetroitCorridors.aspx">Street View: Detroit's Hidden Corridors</a></li>
<li><a href="/series/detroit-innovation.aspx">Detroit Innovation</a></li>
<li><a href="/series/dining-destinations.aspx">Dining Destinations</a></li>

<li><a href="/series/early-education-matters.aspx">Early Education Matters</a></li>
<li><a href="/series/equitable-development.aspx">Equitable Development</a></li>
<li><a href="/series/exploring-economic-equity.aspx">Exploring Economic Equity</a></li>
<li><a href="/series/girl-scouts-se-michigan-team-up.aspx">Girl Scouts SE Michigan Team Up</a></li>
<li><a href="/series/good-food.aspx">Good Food</a></li>
<li><a href="/series/inside-our-outdoors.aspx">Inside our Outdoors</a></li>


<li><a href="/series/marygrove-conservancy.aspx">Marygrove Conservancy</a></li>
<li><a href="/series/michigan-nightlight.aspx">Michigan Nightlight</a></li>

<li><a href="/series/nonprofit-journal-project.aspx">Nonprofit Journal Project</a></li>
<li><span class='treatment-on-the-ground'></span><a href="/series/on-the-ground.aspx">On the Ground</a></li>
<li><a href="/series/partners-in-the-arts.aspx">Parnters in the Arts</a></li>
<li><a href="/series/powering-the-mitten.aspx">Powering the Mitten</a></li>
<li><a href="/series/resilient-neighborhoods.aspx">Resilient Neighborhoods</a></li>
<li><a href="/series/state-of-health.aspx">State of Health</a></li>
<li><a href="/series/stem-hub.aspx">STEM Hub</a></li>
<li><a href="/series/stories-of-change.aspx">Stories of Change</a></li>
<li><a href="/series/voices-of-youth.aspx">Voices of Youth</a></li>

</ul>
</div>
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Events</li>
<li><a href="/speakerseries/">Speaker Series</a></li>
</ul>
</div>
</div>
</ul>
</li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-sm hidden-md hidden-lg">
<li>
<a href="https://www.facebook.com/pages/Detroit-MI/Model-D/59393805320" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/modeld" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a href="https://vimeo.com/user7681011" target="_blank"><img src="/images/vimeo_on.png" alt="Vimeo" /></a>
<a href="https://instagram.com/modeldmedia" target="_blank"><img src="/images/instagram_on.png" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Model D RSS feed!" target="_blank" href="https://feeds.feedburner.com/ModelDMedia"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
<button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target=".navbar-mobile" aria-expanded="false" aria-controls="navbar-top">
<span class="sr-only">Toggle navigation</span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</button>
<div class="navbar-logo"><a href="/"><img class="image-logo" src="/images/logo-modeld.png" alt="Model D" /></a></div>
</div>
<div class="nav navbar-nav navbar-mobile collapse navbar-collapse">
<ul class="nav navbar-nav focus-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Focus Areas<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/focusareas/architecture.aspx'>Architecture</a></li><li><a href='/focusareas/arts.aspx'>Arts</a></li><li><a href='/focusareas/Buildingcommunities.aspx'>Building Communities</a></li><li><a href='/focusareas/entrepreneurs.aspx'>Entrepreneurs</a></li><li><a href='/focusareas/film.aspx'>Film</a></li><li><a href='/focusareas/green.aspx'>Green</a></li><li><a href='/focusareas/greentech.aspx'>Green Tech</a></li><li><a href='/focusareas/highered.aspx'>Higher Ed</a></li><li><a href='/focusareas/Jobcreation.aspx'>Job Creation</a></li><li><a href='/focusareas/michigannightlightfocus.aspx'>Michigan Nightlight</a></li><li><a href='/focusareas/mobility.aspx'>Mobility</a></li><li><a href='/focusareas/movetodetroit.aspx'>Move to Detroit</a></li><li><a href='/focusareas/neighborhoodinnovation.aspx'>Neighborhood Innovation</a></li><li><a href='/focusareas/redevelopment.aspx'>Redevelopment</a></li><li><a href='/focusareas/reuserebuild.aspx'>Reuse / Rebuild</a></li><li><a href='/focusareas/shoplocal.aspx'>Shop Local</a></li><li><a href='/focusareas/smallbusines.aspx'>Small Business</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Innovation</a></li><li><a href='/focusareas/talentdividend.aspx'>Talent Dividend</a></li><li><a href='/focusareas/transit.aspx'>Transit</a></li><li><a href='/focusareas/urbanfarming.aspx'>Urban Farming</a></li><li><a href='/focusareas/urbanleadership.aspx'>Urban Leadership</a></li><li><a href='/focusareas/woodwardave.aspx'>Woodward Avenue</a></li><li><a href='/focusareas/workforcetalentdevelopment812.aspx'>Workforce/talent development</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav subregion-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Neighborhoods<span class="caret"></span></a>
<ul class="dropdown-menu"><li><a href='/cities/brightmoor.aspx'>Brightmoor</a></li><li><a href='/cities/centralwoodward/default.aspx'>Central Woodward-Boston Edison</a></li><li><a href='/cities/cody-rouge.aspx'>Cody Rouge</a></li><li><a href='/cities/corktown/default.aspx'>Corktown</a></li><li><a href='/cities/downtown/default.aspx'>Downtown Detroit</a></li><li><a href='/cities/eriverfront/default.aspx'>East Riverfront</a></li><li><a href='/cities/eastside/default.aspx'>East Side</a></li><li><a href='/cities/easternmarket/default.aspx'>Eastern Market</a></li><li><a href='/cities/grandmtrsdl/default.aspx'>Grandmont Rosedale</a></li><li><a href='/cities/hamtramck/default.aspx'>Hamtramck</a></li><li><a href='/cities/highlandprk/default.aspx'>Highland Park</a></li><li><a href='/cities/jeffeast/default.aspx'>Jefferson Chalmers</a></li><li><a href='/cities/lafayetteprk/default.aspx'>Lafayette Park</a></li><li><a href='/cities/live_6.aspx'>Live 6</a></li><li><a href='/cities/mexicantown/default.aspx'>Mexicantown</a></li><li><a href='/cities/midtown/default.aspx'>Midtown</a></li><li><a href='/cities/neareastside/default.aspx'>Near East Side</a></li><li><a href='/cities/newcenter/default.aspx'>New Center</a></li><li><a href='/cities/north_end.aspx'>North End</a></li><li><a href='/cities/osborn.aspx'>Osborn</a></li><li><a href='/cities/swdetroit/default.aspx'>Southwest Detroit</a></li><li><a href='/cities/thevillages/default.aspx'>The Villages</a></li><li><a href='/cities/univcommons/default.aspx'>University Commons - Palmer Park</a></li><li><a href='/cities/woodbridge/default.aspx'>Woodbridge</a></li></ul>
</li>
</ul>
<ul class="nav navbar-nav resources-nav visible-xs">
<li class="dropdown">
<a href="#" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="true">Series & Events<span class="caret"></span></a>
<ul class="dropdown-menu multi-column columns-2">
<div class="row">
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Series</li>


<li><a href="/series/block-by-block.aspx">Block by Block</a></li>
<li><a href="/series/blue-green-infrastructure.aspx">Blue/Green Infrastructure</a></li>
<li><a href="/series/bridging-the-talent-gap.aspx">Bridging the Talent Gap</a></li>
<li><a href="/series/children-of-michigan.aspx">Children of Michigan</a></li>
<li><a href="/series/community-redistricting.aspx">Community Redistricting</a></li>
<li><a href="/series/voices-of-cody-rouge.aspx">Voices of Cody Rouge</a></li>

<li><a href="/series/detroit-driven.aspx">Detroit Driven</a></li>
<li><a href="/series/DetroitCorridors.aspx">Street View: Detroit's Hidden Corridors</a></li>
<li><a href="/series/detroit-innovation.aspx">Detroit Innovation</a></li>
<li><a href="/series/dining-destinations.aspx">Dining Destinations</a></li>

<li><a href="/series/early-education-matters.aspx">Early Education Matters</a></li>
<li><a href="/series/equitable-development.aspx">Equitable Development</a></li>
<li><a href="/series/exploring-economic-equity.aspx">Exploring Economic Equity</a></li>
<li><a href="/series/girl-scouts-se-michigan-team-up.aspx">Girl Scouts SE Michigan Team Up</a></li>
<li><a href="/series/good-food.aspx">Good Food</a></li>
<li><a href="/series/inside-our-outdoors.aspx">Inside our Outdoors</a></li>


<li><a href="/series/marygrove-conservancy.aspx">Marygrove Conservancy</a></li>
<li><a href="/series/michigan-nightlight.aspx">Michigan Nightlight</a></li>

<li><a href="/series/nonprofit-journal-project.aspx">Nonprofit Journal Project</a></li>
<li><span class='treatment-on-the-ground'></span><a href="/series/on-the-ground.aspx">On the Ground</a></li>
<li><a href="/series/partners-in-the-arts.aspx">Parnters in the Arts</a></li>
<li><a href="/series/powering-the-mitten.aspx">Powering the Mitten</a></li>
<li><a href="/series/resilient-neighborhoods.aspx">Resilient Neighborhoods</a></li>
<li><a href="/series/state-of-health.aspx">State of Health</a></li>
 <li><a href="/series/stem-hub.aspx">STEM Hub</a></li>
<li><a href="/series/stories-of-change.aspx">Stories of Change</a></li>
<li><a href="/series/voices-of-youth.aspx">Voices of Youth</a></li>

</ul>
</div>
<div class="col-sm-6">
<ul class="multi-column-dropdown">
<li class="dropdown-header">Events</li>
<li><a href="/speakerseries/">Speaker Series</a></li>
</ul>
</div>
</div>
</ul>
</li>
</ul>
</div>
<div id="navbar-secondary" class="collapse navbar-collapse navbar-mobile">
<ul class="nav navbar-nav navbar-general">
<li class="active"><a href="/about/about.aspx" class="nav-about">About</a></li>
<li><a href="/about/contactus.aspx" class="nav-contact">Contact</a></li>
</ul>
<ul id="navbar-social" class="nav navbar-nav hidden-xs">
<li>
<a href="https://www.facebook.com/pages/Detroit-MI/Model-D/59393805320" target="_blank" title=""><img src="/images/facebook_on.png" alt="Facebook" /></a>
<a href="https://twitter.com/modeld" target="_blank"><img src="/images/twitter_on.png" alt="Twitter" /></a>
<a href="https://vimeo.com/user7681011" target="_blank"><img src="/images/vimeo_on.png" alt="Vimeo" /></a>
<a href="https://instagram.com/modeldmedia" target="_blank"><img src="/images/instagram_on.png" /></a>
<a type="application/rss+xml" rel="alternate" title="Subscribe to the Model D RSS feed!" target="_blank" href="https://feeds.feedburner.com/ModelDMedia"><img src="/images/rss_on.png" alt="RSS Feed" /></a>
<a class="search" href="#" onclick="$('.searchContainer').fadeToggle(); $('#q').focus(); return false;"><img src="/images/icon_search.png" /></a>
<div class="searchContainer"><input class="searchBox" id="q" name="q" type="text" onkeydown="return SubmitOnEnter(this,event,'');" /></div>
</li>
</ul>
</div>
</div>
</nav>
</div>
</div>
</div>
<div class="container-fluid contentSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="row">
<div class="col-md-12 page-heading">
<h1 class="page-title" style='x'>At The Corner in Ypsi, young people find health care that's affordable, holistic and judgement-free<span class='subtitle'>The Nonprofit Journal Project</span></h1>
<div class="byline" style='x'>
<span class="author">Versell Smith, Jr.</span> |
<span class="date">Wednesday, April 13, 2022</span>
</div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" onclick="ga('send','social','facebook','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;text=At+The+Corner+in+Ypsi%2c+young+people+find+health+care+that%27s+affordable%2c+holistic+and+judgement-free" onclick="ga('send','social','twitter','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;title=At+The+Corner+in+Ypsi%2c+young+people+find+health+care+that%27s+affordable%2c+holistic+and+judgement-free" onclick="ga('send','social','linkedin','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="/cdn-cgi/l/email-protection#c4fb86aba0bdf9acb0b0b4b7e1f7a5e1f6a2e1f6a2b3b3b3eaa9aba0a1a8a0a9a1a0ada5eaa7aba9e1f6a2a2a1a5b0b1b6a1b7e1f6a285b0e9b0aca1e987abb6aaa1b6e9adaae99db4b7ade9bdabb1aaa3e9b4a1abb4a8a1e9a2adaaa0e9aca1a5a8b0ace9a7a5b6a1e9b0aca5b0b7e9a5a2a2abb6a0a5a6a8a1e9acaba8adb7b0ada7e9a5aaa0e9aeb1a0a3a1a9a1aab0eaa5b7b4bce2a5a9b4ff97b1a6aea1a7b0f997aca5b6a1fe85b0ef90aca1ef87abb6aaa1b6efadaaef9db4b7ade1f6a7efbdabb1aaa3efb4a1abb4a8a1efa2adaaa0efaca1a5a8b0acefa7a5b6a1efb0aca5b0e1f6f3b7efa5a2a2abb6a0a5a6a8a1e1f6a7efacaba8adb7b0ada7efa5aaa0efaeb1a0a3a1a9a1aab0e9a2b6a1a1" onclick="ga('send','social','email','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
        </script>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12 col-md-8">
<div id="main-content" class='content-block '>
<div class="featuredImage">
<div class="overlay"></div>
<div id="ctl00_ContentPlaceHolder1_ctl03" class="mediaGallery caption-below mode-lazy featured-media-gallery">
<div class="carousel carousel-main" data-flickity='{ "cellAlign":"left", "contain": true, "wrapAround": true, "autoPlay": false, "pauseAutoPlayOnHover": true, "fullscreen": true, "fade": true, "adaptiveHeight": true, "imagesLoaded": true, "lazyLoad":true, "cellSelector": ".carousel-cell", "setGallerySize": true, "prevNextButtons": false, "pageDots": false }'>
<div class="carousel-cell">
<div class=" cell-item">
<div class="carousel-image-container image-vertical">
<img class="carousel-image " alt="Versell Smith, Jr." sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px" data-flickity-lazyload-srcset="/Images/Features/versell-smith-cropped-photo-2_1.jpg?s=t 120w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=l 265w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=lf 500w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=f 750w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=m 980w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=p 1125w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=mx 1600w" data-flickity-lazyload-src="/Images/Features/versell-smith-cropped-photo-2_1.jpg" />
<noscript>
 <img class="carousel-image "
      alt="Versell Smith, Jr."
      sizes="(min-width:1200px) 1600px, (min-width:1080px) 1125px, (min-width:850px) 980px, (min-width:571px) 750px, (min-width:400px) 500px, (min-width:200px) 265px, 265px"
      srcset="/Images/Features/versell-smith-cropped-photo-2_1.jpg?s=t 120w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=l 265w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=lf 500w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=f 750w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=m 980w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=p 1125w, /Images/Features/versell-smith-cropped-photo-2_1.jpg?s=mx 1600w"
      src="/Images/Features/versell-smith-cropped-photo-2_1.jpg"
     />
 </noscript>
</div>
<div class="captionOverlay"><div class="captionText">Versell Smith, Jr. <span class='image-credits'></span></div></div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_MastHeadAdZone">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Masthead Leaderboard');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=40eb09deb5324b1aa396f0a85c465de1&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3098&amp;cb=31303404378&amp;n=40eb09deb5324b1aa396f0a85c465de1&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="body">
Forty-one years ago, <a express="" href="http://Recently,%20we%20received%20a%20highly%20competitive%20national%20grant%20from%20the%20CDC,%20called" yourself="">The Corner Health Center </a>in Ypsilanti became the first school-based health center in the state of Michigan. As a result, we remain the gold standard in child and adolescent health care today.&nbsp;<br>
<br>
We&#39;re called, &#34;The Corner,&#34; because we originated in the corner of Ypsilanti High School. It was actually a small janitorial closet, donated to us by Washtenaw County, from which we provided young people medical and support services with a focus on the needs of young teen moms. Today, our integrated health center provides a broad range of judgment-free, high-quality, affordable health services to young people ages 12 to 25, and their children.<br>
<br>
Judgment-free means we&#39;re a safe place where people can be their authentic selves. When legislation passed prohibiting the distribution of contraceptives on school property, we made the tough decision to move off-site to continue fulfilling our mission. We launched a capital campaign to found The Corner in downtown Ypsilanti, and changed our distinction from a school-based health center to a school-linked one.<br>
<br>
Today, at one location, we provide mental health and behavioral health services alongside medical care. We&nbsp;have allergy and immunology, OBGYN, med-peds, adolescent health, and pain and addiction physicians. Our unique wrap-around services include an on-site pantry and a care manager who helps our patients find jobs, and connects those in need with housing and utility assistance.&nbsp;<br>
<br>
Through word of mouth, our LGBTQ services and gender care are sought out by young people near and far. Although our primary focus has always been Ypsi&#8217;s 48197 and 48198 zip codes, our patients come to us from Wayne County, Ann Arbor, the Upper Peninsula and out of state. Many cannot receive this type of care in their small towns.&nbsp;<br>
<br>
Even this year, many of our young expecting mothers have been isolated with COVID-19. We&#39;ve quickly pivoted to support them by delivering food, running errands and converting their appointments online. At the beginning of the pandemic, we received surprise funding from the Meijer Foundation to help us purchase equipment to pivot to telehealth with great ease.&nbsp;<br>
<br>
We&#39;ve been strengthened by many valuable partnerships including St. Joe&#8217;s, U of M, Community Mental Health and United Way. I&#8217;m so thankful to be a part of Washtenaw County where these can happen. We also have the best donors on earth, who have continually reached out to ask how our patients, and my staff and I are doing.<br>
<br>
When we look at COVID-19, and the death rates, we know they provide a measurement of our community&#8217;s overall health needs. Only 12 percent of Washtenaw County is Black, but that population represents 41 percent of COVID-19 hospitalizations, and primarily live in Ypsilanti.&nbsp;Black infants are four times more likely to die within the first year than white infants, and their Black mothers have higher mortality rates for childbirth. The life expectancy of young Black men is significantly reduced if you turn left out of St. Joe&#8217;s heading into Ypsi rather than right into Ann Arbor. The Corner has always been at the forefront of these health inequities.&nbsp;<br>
<br>
But our needs increase. We have a six-month waitlist for our mental health providers. We need to hire more therapists and mental health staff. When a young person comes forward to say, I need help, we need to be able to deliver help to them that day. Trying to figure out how we get ahead of this is one thing that keeps me up at night.&nbsp;We also need improved funding. With the &#8216;Great Resignation&#8217; in healthcare, there are challenges with attrition. We can&#8217;t afford to pay what others can pay and so we struggle to attract and retain talent. Our staff love our mission, but we sometimes have challenges meeting them where they need to be.<br>
<br>
Affordable healthcare, I&#39;m proud to say, means we don&#39;t turn anyone away. We see patients whether they&#39;re fully-insured, uninsured or underinsured. If a young person is on their parent&#39;s insurance, but come to receive confidential services, which they can by law, we provide that service for free. My job as a fundraiser is to make sure we have a sufficient patient resource fund to help cover expenses.&nbsp;<br>
<br>
I take tremendous pride in the creativity and innovation of The Corner. It&#8217;s something our staff here value as well. We&#39;re out-of-the-box thinkers who tend to say yes, more than we say no. Everything we do is aligned with our mission, but as we move forward, we&#39;re looking at new ways to engage with our patients and community.&nbsp;As an African American leader, I don&#39;t take my position lightly. I know there&#39;s much that can be done, and needs to be done to help address the inequities.<br>
<br>
Our <a href="https://www.secondwavemedia.com/concentrate/innovationnews/washtenawcovidcultural0634.aspx" target="_blank">peer-to-peer theater troupe</a> is truly a unique aspect of our health center. Our young people meet weekly to develop plays focused on health topics like COVID-19, substance use, sexually-transmitted infections, date rape, online bullying, etc. Working with a theater director and a social worker, they craft a 20-minute play highlighting these issues and we go into schools and community centers and perform the play for students.&nbsp;<br>
<br>
This outreach allows us to fully capture the youth voice, a key aspect to our work, and lets students hear directly from their peers. It raises awareness and education, but also provides those in the audience with resources, and what to look for. They learn they can come to The Corner to speak with someone confidentially about any topic. We&#8217;re also building cultural competencies with adults. We&#39;ve seen parents have some real a-ha moments understanding what their young person is experiencing.<br>
<br>
Recently, at one of our COVID-19 vaccination clinics, I met a woman who was a patient of ours when she gave birth to a healthy baby daughter without any family support. Her daughter also became our patient, and now, she was bringing her grandchildren to get vaccinated. She told me how critically important we are in the community as a grassroots organization solely focused on young people, and on making African American lives a priority. It was a rare gift for me to hear firsthand the impact our work is having on multiple generations. These are the moments that inspire me.&nbsp;<br>
<br>
<br>
<em>Versell Smith, Jr. is the executive director at <a href="https://www.cornerhealth.org/?module=Page" target="_blank">The Corner Health Center</a> in Ypsilanti. This entry is part of our&nbsp;</em><a href="https://www.secondwavemedia.com/series/nonprofit-journal-project.aspx"><em>Nonprofit Journal Project</em></a><em>, an initiative inviting nonprofit leaders across Metro Detroit to contribute their thoughts via journal entries on how COVID-19, a heightened awareness of racial injustice and inequality, issues of climate change and more are affecting their work--and how they are responding. This series is made possible with the generous support of our partners, the Michigan Nonprofit Association and Co.act Detroit.</em><br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
&nbsp;

</div>
<div class="clear"></div>
<div class="contentMeta">
<div class="share">
<span class="shareText">Share</span>
<span class="buttons">
<a class="shareFacebook" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" onclick="ga('send','social','facebook','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_facebook.png" alt="Share on Facebook" /></a>
<a class="shareTwitter" target="_blank" href="https://twitter.com/share?url=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;text=At+The+Corner+in+Ypsi%2c+young+people+find+health+care+that%27s+affordable%2c+holistic+and+judgement-free" onclick="ga('send','social','twitter','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_twitter.png" alt="Share on Twitter" /></a>
<a class="shareLinkedin" target="_blank" href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3a%2f%2fwww.modeldmedia.com%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;title=At+The+Corner+in+Ypsi%2c+young+people+find+health+care+that%27s+affordable%2c+holistic+and+judgement-free" onclick="ga('send','social','linkedin','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_linkedin.png" alt="Share on LinkedIn" /></a>
<a class="shareMailto" href="/cdn-cgi/l/email-protection#1e215c717a6723766a6a6e6d3b2d7f3b2c783b2c786969693073717a7b727a737b7a777f307d71733b2c78787b7f6a6b6c7b6d3b2c785f6a336a767b335d716c707b6c33777033476e6d773367716b7079336e7b716e727b337877707a33767b7f726a76337d7f6c7b336a767f6a6d337f7878716c7a7f7c727b33767172776d6a777d337f707a33746b7a797b737b706a307f6d6e66387f736e254d6b7c747b7d6a234d767f6c7b245f6a354a767b355d716c707b6c35777035476e6d773b2c7d3567716b7079356e7b716e727b357877707a35767b7f726a76357d7f6c7b356a767f6a3b2c296d357f7878716c7a7f7c727b3b2c7d35767172776d6a777d357f707a35746b7a797b737b706a33786c7b7b" onclick="ga('send','social','email','send','/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx');"><img src="/images/share_email.png" alt="Share through Email" /></a></span>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
        </script>
</div>
<div class="toolBar">
<div class="toolBarLike">
<div id="fb-like" class="fb-like" data-href="https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" data-width="" data-layout="button_count" data-action="like" data-size="small" data-share="false"></div>
<script>facebookComponents.register('fb-like');</script>
</div>
</div>
</div>
<div class="authorSection">
<div class="clear"></div>
</div>
<div class="contentMeta">
<div class="relatedContent">
<h4>Related Tags</h4>
<div class="tags separator">
<a title="View more stories related to Nonprofit Journal Project" href="/tags/taghome.aspx?tag=Nonprofit+Journal+Project">Nonprofit Journal Project</a>&nbsp;
</div>
</div>
</div>
<div id="commentsContainer" class="commentsContainer">
<a name="comments"></a>
<div id="fb-comments" class="fb-comments" data-href="https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx" data-width="560" data-numposts="100"></div>
<script>
facebookComponents.register('fb-comments');
</script>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl11">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Leaderboard 2');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=bf687f60de1f4b4d9e2e61be479bf97b&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3106&amp;cb=31303404378&amp;n=bf687f60de1f4b4d9e2e61be479bf97b&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="leaderboard">

<div class="adzone " id="ctl00_ContentPlaceHolder1_ctl12">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Leaderboard 3');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=f09df6544a434281bf5a44ff1c79411b&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3107&amp;cb=31303404378&amp;n=f09df6544a434281bf5a44ff1c79411b&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
<div class="col-xs-12 col-md-4">
<div class="row">
<div class="col-xs-12">
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone7">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Half Page 1');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=37b1335a97f749e9a07d763ac1c0eccb&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=5755&amp;cb=31303404378&amp;n=37b1335a97f749e9a07d763ac1c0eccb&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="columnList partnerLinks">
<h3>Recommended Content</h3>
<div class="clearfix">
<div>
</div>
</div>
<script type="text/javascript">InitializePartnerLinks();</script>
</div>
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone1">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 1');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=5c5790b7728e4d248b068f9e73a265e4&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3100&amp;cb=31303404378&amp;n=5c5790b7728e4d248b068f9e73a265e4&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone8">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 2');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=bbcc62d49076422b8664207607904603&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3101&amp;cb=31303404378&amp;n=bbcc62d49076422b8664207607904603&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div id="sidebar-content" class='content-block'>
<div class="bodyRight">
</div>
</div>
</div>
<div class="col-xs-12">
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone2">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 3');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=97fb7beb3b5f44f1b825727bede623cb&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3102&amp;cb=31303404378&amp;n=97fb7beb3b5f44f1b825727bede623cb&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<div class="col-xs-12 hidden-xs hidden-sm">
<div id="ctl00_ContentPlaceHolder1_PopularPages_PopularPagesAjaxContainer"></div>
<script type="text/javascript">
//<![CDATA[
    $("#ctl00_ContentPlaceHolder1_PopularPages_PopularPagesAjaxContainer").load("/Controls/TopPages.aspx?numberOfPages=10&preTitle=Top+&title=Stories&maxPageTitleLength=-1&pathFilterStartsWith=%2froot&windowLengthInDays=14&cacheKey=IssueMediaGroup.PopularPages.Stories&cacheExpirationMinutes=0&removeEntriesPriorToWindowStart=False&cssClass=&listCssClass=&baseDirectoryPath=%2froot%2fstories&adZoneName=&abstractOnFirst=False #popularPageContainer");
//]]>
</script>
<script type="text/javascript">IMG_axs('pv', '3f05fb6b-5498-426b-a381-a37dc7db76ec');</script>
</div>
<div class="col-xs-12">
<div class="towerad-container">

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone4">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 4');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=1ed4fc45e41e4c629bd11a30f72e20de&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3103&amp;cb=31303404378&amp;n=1ed4fc45e41e4c629bd11a30f72e20de&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone5">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 5');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=7b024247ed3e41f8969f1356fd988af4&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3104&amp;cb=31303404378&amp;n=7b024247ed3e41f8969f1356fd988af4&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>

<div class="adzone " id="ctl00_ContentPlaceHolder1_AdZone6">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Rectangle 6');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=ab6c4e40714d4bef9dc5a6f134efd957&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=3105&amp;cb=31303404378&amp;n=ab6c4e40714d4bef9dc5a6f134efd957&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12 hidden-xs hidden-sm">
<div class="columnList network horizontal">
<h3>
Across Our Network
</h3>
<div class="clearfix">
<div>
<ul class="textWrapList noBullets">
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/metromode/features/BommaritoBakery.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/metromode/filterd/images/bakeryb.jpg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/metromode/filterd/images/bakeryb.jpg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/metromode/features/BommaritoBakery.aspx" target="_blank">How a small Italian bakery grew into a 90-year-old family legacy</a>
<div id="ctl00_ContentPlaceHolder1_ctl15_RepeaterColumns_ctl01_Div1" class="additionalattribute">
Source: Metromode
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/southwest-michigan/features/Let-there-be-more-light-say-resident-empowerment-groups-working-to-stop-unwanted-%20traff-033122.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/southwest-michigan/galleries/image5_1_1.jpeg?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/southwest-michigan/galleries/image5_1_1.jpeg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/southwest-michigan/features/Let-there-be-more-light-say-resident-empowerment-groups-working-to-stop-unwanted-%20traff-033122.aspx" target="_blank">Let there be more light, say resident-empowerment groups working together in Kalamazoo</a>
<div id="ctl00_ContentPlaceHolder1_ctl15_RepeaterColumns_ctl02_Div1" class="additionalattribute">
Source: Southwest Michigan's Second Wave
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.flintside.com/inthenews/literacy-for-life.aspx" target="_blank">
<noscript><img src="https://www.flintside.com/galleries/literacy.jpeg?s=l" class="thumb"></noscript>
<img data-src="https://www.flintside.com/galleries/literacy.jpeg?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.flintside.com/inthenews/literacy-for-life.aspx" target="_blank">The CFGF aims to close the literacy gap in Genesee County with 'Literacy for Life' initiative</a>
<div id="ctl00_ContentPlaceHolder1_ctl15_RepeaterColumns_ctl03_Div1" class="additionalattribute">
Source: Flintside
</div>
<div class="clear"></div>
</li>
<li>
<div class="listImage thumb">
<a href="https://www.secondwavemedia.com/concentrate/innovationnews/sacpovertysolutions0632.aspx" target="_blank">
<noscript><img src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_632/expulsion_map.png?s=l" class="thumb"></noscript>
<img data-src="https://www.secondwavemedia.com/concentrate/images/Features/Issue_632/expulsion_map.png?s=l" class="lazy-load thumb">
</a></div>
<a href="https://www.secondwavemedia.com/concentrate/innovationnews/sacpovertysolutions0632.aspx" target="_blank">Ypsi nonprofit uses U-M research to help Michigan school districts prevent expulsions</a>
<div id="ctl00_ContentPlaceHolder1_ctl15_RepeaterColumns_ctl04_Div1" class="additionalattribute">
Source: Concentrate
</div>
<div class="clear"></div>
</li>
</ul>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid contentSection2 no-padding">
<div class="container-fluid container-inner no-padding">
</div>
</div>
<div class="container-fluid footerAdsSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="byline">Sponsored By</div>
<div id="footeradholder">
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone1">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 01');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=85928b72dffc427bad37ec716c724f26&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2513&amp;cb=31303404378&amp;n=85928b72dffc427bad37ec716c724f26&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone2">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 02');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=64c9f1502fa84aa2abc9e47e0d5fa599&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2514&amp;cb=31303404378&amp;n=64c9f1502fa84aa2abc9e47e0d5fa599&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone3">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 03');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=52cb3613e9274e068140ad6e387da40d&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2515&amp;cb=31303404378&amp;n=52cb3613e9274e068140ad6e387da40d&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone4">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 04');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=1b83d22660a14609a86570f221f36166&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2516&amp;cb=31303404378&amp;n=1b83d22660a14609a86570f221f36166&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone5">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 05');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=6136de654eb84779a1d2cdbfc0e9de54&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2517&amp;cb=31303404378&amp;n=6136de654eb84779a1d2cdbfc0e9de54&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone6">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 06');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=59c3abf3db0f43cbaed42c33c77d1bae&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2518&amp;cb=31303404378&amp;n=59c3abf3db0f43cbaed42c33c77d1bae&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
<div id="row" class="row">
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone7">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 07');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=9ecf54d4c1a443eeafdb2f15c0622cd0&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2519&amp;cb=31303404378&amp;n=9ecf54d4c1a443eeafdb2f15c0622cd0&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone8">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 08');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=6d38b6a12de8432b84d54cd14234d1b8&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2520&amp;cb=31303404378&amp;n=6d38b6a12de8432b84d54cd14234d1b8&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone9">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 09');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=78e6d6ae66694dde81beda39c4a4e7a8&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2521&amp;cb=31303404378&amp;n=78e6d6ae66694dde81beda39c4a4e7a8&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone10">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 10');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=11ea63c99a5f4206af8d96d23ebb6245&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2522&amp;cb=31303404378&amp;n=11ea63c99a5f4206af8d96d23ebb6245&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone11">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 11');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=8b6e20e2ec604860b4d6968d84a0909d&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2523&amp;cb=31303404378&amp;n=8b6e20e2ec604860b4d6968d84a0909d&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
<div class="col-xs-6 col-sm-4 col-md-2 footerad">

<div class="adzone " id="ctl00_Footer1_AdZone12">
<script type='text/javascript'><!--    // <![CDATA[
    OA_show('Footer 12');
// ]]> --></script><noscript><a rel="nofollow" href='https://dsx.issuemediagroup.com/www/delivery/ck.php?n=20e70ae51b224c5c9722093ac45da0d0&amp;cb=31303404378' target='_blank'><img src='https://dsx.issuemediagroup.com/www/delivery/avw.php?pubid=20&amp;zoneid=2524&amp;cb=31303404378&amp;n=20e70ae51b224c5c9722093ac45da0d0&amp;Page=20~%2ffeatures%2fAt-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx&amp;Tag=20%7eNonprofit+Journal+Project' border='0' alt='' /></a></noscript>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container-fluid footerSection no-padding">
<div class="container-fluid container-inner no-padding">
<div class="container">
<div class="row">
<div class="col-sm-7 col-lg-6 footer-focus-areas">
Focus Areas
<ul><li><a href='/focusareas/architecture.aspx'>Architecture</a></li><li><a href='/focusareas/neighborhoodinnovation.aspx'>Neighborhood Innovation</a></li><li><a href='/focusareas/arts.aspx'>Arts</a></li><li><a href='/focusareas/redevelopment.aspx'>Redevelopment</a></li><li><a href='/focusareas/Buildingcommunities.aspx'>Building Communities</a></li><li><a href='/focusareas/reuserebuild.aspx'>Reuse / Rebuild</a></li><li><a href='/focusareas/entrepreneurs.aspx'>Entrepreneurs</a></li><li><a href='/focusareas/shoplocal.aspx'>Shop Local</a></li><li><a href='/focusareas/film.aspx'>Film</a></li><li><a href='/focusareas/smallbusines.aspx'>Small Business</a></li><li><a href='/focusareas/green.aspx'>Green</a></li><li><a href='/focusareas/socialinnovation.aspx'>Social Innovation</a></li><li><a href='/focusareas/greentech.aspx'>Green Tech</a></li><li><a href='/focusareas/talentdividend.aspx'>Talent Dividend</a></li><li><a href='/focusareas/highered.aspx'>Higher Ed</a></li><li><a href='/focusareas/transit.aspx'>Transit</a></li><li><a href='/focusareas/Jobcreation.aspx'>Job Creation</a></li><li><a href='/focusareas/urbanfarming.aspx'>Urban Farming</a></li><li><a href='/focusareas/michigannightlightfocus.aspx'>Michigan Nightlight</a></li><li><a href='/focusareas/urbanleadership.aspx'>Urban Leadership</a></li><li><a href='/focusareas/mobility.aspx'>Mobility</a></li><li><a href='/focusareas/woodwardave.aspx'>Woodward Avenue</a></li><li><a href='/focusareas/movetodetroit.aspx'>Move to Detroit</a></li><li><a href='/focusareas/workforcetalentdevelopment812.aspx'>Workforce/talent development</a></li></ul>
</div>
<div class="col-sm-5 col-lg-2 footer-links">
<ul>
<li><a href="/about/About.aspx">About Model D</a></li>
<li><a href="/about/ContactUs.aspx">Contact Us</a></li>
<li><a href="/about/DetroitLinks.aspx">Detroit Links</a></li>
<li><a href="/about/Tips.aspx">Have a Tip?</a></li>
<li><a href="/about/PrivacyPolicy.aspx">Privacy Policy</a></li>
<li><a href="/about/TermsOfUse.aspx">Terms of Use</a></li>
</ul>
</div>
</div>
<div class="row">
<div class="col-md-12">Copyright &copy; Issue Media Group. All rights reserved.</div>
</div>
</div>
</div>
</div>
</div>
<script>
var pageInfo = {"article":true,"post_id":"3f05fb6b-5498-426b-a381-a37dc7db76ec","post_type":"Featured Story","taxonomies":{"tags":["Nonprofit Journal Project"]},"url":"https://www.modeldmedia.com/features/At-the-Corner-in-Ypsi-young-people-find-health-care-thats-affordable-holistic-and-judgement.aspx"};
if (window.pico) {
    window.pico('visit', pageInfo);
}
</script>
<div>
<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="A9D29ECE" />
</div></form>
<script src="https://cdnjs.cloudflare.com/ajax/libs/flickity/2.2.1/flickity.pkgd.min.js" integrity="sha256-3Maq7M1TC8sOke8B4gRkhfGtETqGWq+xenQO7k2mHjI=" crossorigin="anonymous"></script>
<script src="https://unpkg.com/flickity-fullscreen@1.1.1/fullscreen.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/vanilla-lazyload/17.3.0/lazyload.min.js"></script>
<script>
var lazyLoadInstance = new LazyLoad({
    elements_selector: ".lazy-load",
    callback_loaded: lazyloadCallback
});
</script>
</body>
</html>
